Skip to content

Instantly share code, notes, and snippets.

@ascendbruce
ascendbruce / README.md
Last active April 6, 2025 21:57
Use macOS-style shortcuts in Windows

Use macOS-style shortcuts in Windows / keyboard mappings using a Mac keyboard on Windows

ℹ️ There is a newer alternative project that does similar things and more, check it out at https://github.com/stevenilsen123/mac-keyboard-behavior-in-windows

Make Windows PC's shortcut act like macOS (Mac OS X) (using AutoHotkey (ahk) script)

With this AutoHotKey script, you can use most macOS style shortcuts (eg, cmd+c, cmd+v, ...) on Windows with a standard PC keyboard.

How does it work

@DanielVF
DanielVF / sample.md
Last active April 6, 2025 21:55
Sample Vulnerability Report

Impact

CRITICAL! Almost all USDC liquidity on the REKT/USDC uniswap pool can be stolen, due to an authorization issue with burnFrom() on the REKT token.

Background

Uniswap v2 pools get the prices for their swaps by comparing the relative amounts of each of the two tokens that they hold. If the pool holds very little of token A, and a lot of token B, then it only takes a little of token A to buy a lot of token B.

Currently REKT and USDC are fairly priced in the pool. If there were to suddenly be very little REKT in the pool, but the same amount of USDC, then very little REKT would be able to buy a lot of USDC.

@wtw24
wtw24 / docker_rus.md
Last active April 6, 2025 21:54
Шпаргалка с командами Docker

Шпаргалка с командами Docker

1552317264965 1552317537397 1552317711879

1552318467562 1552318531067 1552318577900 1552318614839

@HeratPatel
HeratPatel / git-flow.md
Last active April 6, 2025 21:54
Git Flow: Git branches workflow for larger and continues releasing projects. #git #gitflow

Git Flow: A Successful Git branching model

Alt Text

Gitflow is a Git workflow design that was first published and made popular by Vincent Driessen at nvie. The Gitflow defines a strict branching model designed around the project release. This provides a robust framework for managing larger projects.

Gitflow is ideally suited for projects that have a scheduled release cycle. This workflow doesn’t add any new concepts or commands beyond what’s required for the Feature Branch Workflow. Instead, it assigns very specific roles to different branches and defines how and when they should interact. In addition to feature branches, it uses individual branches for preparing, maintaining, and recording releases. Of course, you also get to leverage all the benefits of the Feature Branch Workflow: pu

@elledienne
elledienne / zero.mdc
Last active April 6, 2025 21:50
Zero Custom Mutators MDC
# Instructions for Using Zero Custom Mutators
## Overview
Zero Custom Mutators provide a powerful mechanism for defining data write operations beyond simple CRUD. They allow you to embed arbitrary code within your write logic, running both client-side for optimistic updates and server-side for authority and complex operations.
**Key Concepts:**
- **Arbitrary Code:** Mutators are functions, enabling complex validation, permissions, calling external services (like LLMs or sending emails), calling queue, etc.
- **Client-Side Execution:** Mutators run immediately on the client for instant UI feedback.
@Pliner
Pliner / import
Last active April 6, 2025 21:49
Mikrotik antifilter.download update script
:do {
:do {
/file remove "/ipsum.rsc";
/file remove "/subnet.rsc";
} on-error={}
:put "Downloading ipsum.rsc...";
:do {
/tool fetch url="https://antifilter.download/list/ipsum.rsc" dst-path="/ipsum.rsc"
} on-error={
@bmaupin
bmaupin / open-source-sso.md
Last active April 6, 2025 21:43
Comparison of some open-source SSO implementations

ⓘ This list is not meant to be exhaustive and is not guaranteed to be maintained. See the comments for updates and alternative options.

(Items in bold indicate possible concerns)

Keycloak WSO2 Identity Server Gluu CAS OpenAM Shibboleth IdP
OpenID Connect/OAuth support yes yes yes yes yes yes
Multi-factor authentication yes yes yes yes yes yes
Admin UI yes yes yes yes yes no
OpenJDK support yes yes partial² yes

The CBPastes Formatting Specification

A more human-readable text standard for sharing tape builds in Cassette Beasts

by Lerycide

v2.0.1: Fixed an issue with move parsing

v2.0: Added support for attributes

v1.0.1: Made minor changes to the string conversion parsing.

@kjy00302
kjy00302 / hpbunpack.py
Last active April 6, 2025 21:41
HuneX hph/hpb unpacker for Nijigasaki VN Switch Demo
import struct
from zlib import crc32
from pathlib import Path
import sys
# Based on https://github.com/YuriSizuku/GalgameReverse/blob/master/project/hunex/src/hunex_hpb.py
packname = sys.argv[1]
f = open(f'{packname}.hph', 'rb')
@kjy00302
kjy00302 / heslunpack.py
Created February 17, 2025 16:48
HuneX heslnk unpacker for Nijigasaki VN Switch Demo
import struct
import lzss # install pylzss, not lzss (requires initial buffer value argument)
import os
def readuntilnull(f):
buf = b''
while True:
data = f.read(16)
offset = data.find(b'\0')